IBM AIX 5.3/6.1/7 上可用的openssh + openssl 工具包。 安装方法: 1、解压rar 2、ftp上传到aix主机 3、使用 gunzip 或 uncompress 解压为tar文件 4、使用tar指令解压 5、使用 smit installp 进行安装
2022-03-25 15:04:15 11.81MB openssh openssl
1
untrusted comment: signature from openbsd 5.5 base secret key RWRGy8gxk9N930mZSNhSVZg9DPFLNT0qQcEGhQeQ55awDf4RfJqPXB6lz71jQatqYzr3XkzyUyckpP4nSCE+XmoICZEPwVhjhA8= OpenBSD 5.5 errata 2, Apr 8, 2014: Missing bounds checking in OpenSSL's implementation of the TLS/DTLS heartbeat extension (RFC6520) which, if exploited, can result in a leak of memory contents. After patching, private keys and certificates exposed to services running this code (for example web/mail server SSL certificates) should be replaced and old certificates revoked. Only SSL/TLS services are affected. Software that uses libcrypto alone is not affected. In particular, ssh/sshd are not affected and there is no need to regenerate SSH host keys that have not otherwise been exposed. Apply patch using: signify -Vep /etc/signify/openbsd-55-base.pub -x 002_openssl.patch.sig \ -m - | (cd /usr/src && patch -p0) Then build and install libssl cd /usr/src/lib/libssl/ssl make obj make make install Also recompile any statically-linked binaries depending on it - in the base OS, this is just ftp(1): cd /usr/src/usr.bin/ftp make obj make clean make make install Then restart services which depend on SSL. Index: lib/libssl/src/ssl/d1_both.c =================================================================== RCS file: /cvs/src/lib/libssl/src/ssl/d1_both.c,v retrieving revision 1.2 diff -u -p -r1.2 d1_both.c --- lib/libssl/src/ssl/d1_both.c 27 Feb 2014 21:04:57 -0000 1.2 +++ lib/libssl/src/ssl/d1_both.c 8 Apr 2014 00:22:22 -0000 @@ -1459,26 +1459,36 @@ dtls1_process_heartbeat(SSL *s) unsigned int payload; unsigned int padding = 16; /* Use minimum padding */ - /* Read type and payload length first */ - hbtype = *p++; - n2s(p, payload); - pl = p; - if (s->msg_callback) s->msg_callback(0, s->version, TLS1_RT_HEARTBEAT, &s->s3->rrec.data[0], s->s3->rrec.length, s, s->msg_callback_arg); + /* Read type and payload length first */ + if (1 + 2 + 16 > s->s3->rrec.length) + return 0; /* silently discard */ + hbtype = *p++; + n2s(p, payload); + if (1 + 2 + payload + 16 > s->s3->rrec.length) + return 0; /* silently discard per RFC 6520 sec. 4 */ + pl = p; + if (hbtype == TLS1_HB_REQUEST) { unsigned char *buffer, *bp; + unsigned int write_length = 1 /* heartbeat type */ + + 2 /* heartbeat length */ + + payload + padding; int r; + if (write_length > SSL3_RT_MAX_PLAIN_LENGTH) + return 0;
2022-03-25 14:39:45 1.06MB openssh5.8
1
openssh5.3.tar
2022-03-14 01:07:50 897KB openssh5.3
1
openssh_5.2p1_aix61.tar.Z OS:AIX6.1 1)解压 #cd /tmp/openssh #gunzip openssh_5.2p1_aix61.tar.Z #tar xvf openssh_5.2p1_aix61.tar 2)安装 使用smitty install来安装。(必须先安装openssl,然后再安装openssh) #cd /tmp/openssl #smitty install 选择Install and Update Software->Install Software,出现操作界面。注意下面的选项的就可以了。 INPUT device / directory for software [.] 输入当前目录. SOFTWARE to install [_all_latest] 按F4、/然后查找ssl匹配项,选中回车 "ACCEPT new license agreements?" [yes] (Tab键)
2021-12-23 15:39:52 5.28MB openssh5.2p1 aix61 openssh AIX6.1
1